# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[[:alnum:]]"
test_str = ("MS-05B\n"
"05B-MS\n"
"ザク MS 05B\n"
"(旧ザク)MS-05B ザクI\n"
"MS: 05B\n"
";MS;\n"
"\"MS\"\n"
"'MS'\n"
"MS.MS,MS\n"
"[MS]\n"
"{MS}\n\n"
"MS -- 改行は境界扱い\n\n"
"(MS) -- 全角記号は境界扱い\n"
"{MS}\n\n\n"
"-- 数値は境界扱いされない\n"
"001MS999\n"
"-- 非アルファベット文字が境界扱いされる(PCRE/JS/Python/Golang)\n"
"ザクMSザク\n"
"量産MS量産")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.