import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"btn (.*?)<\\/div>";
final String string = "<div class=\"btn btn-success\" ng-show=\"beingEdited\" ng-disabled=\"ncrForm.$invalid\" ng-click=\"save()\"><span translate=\"ACTIONS.SAVE\">Kaydet</span></div>\n";
final String subst = "<span class=\"$1</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}