$re = '/(.*)(\w)\*(.*)/m';
$str = 'This is ju* an example
This is * an example
T* is just an example
* is just an example
This is just an ex*
This is just an *';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);