re = /(.*)(\w)\*(.*)/m
str = 'This is ju* an example
This is * an example
T* is just an example
* is just an example
This is just an ex*
This is just an *'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end