#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "SN=([A-Z]+:[\d-]+):"
Local $sString = "SIGN="000F 0E70 FA83 B72F D215 C7EE 4AF4 6440 A547 12B1 0603 \" & @CRLF & _
"" & @CRLF & _
"SN=RK:7573-0:2832397:369963" & @CRLF & _
"" & @CRLF & _
"1086 0857 BFF1 5FC2 CE6F C87D 7C00 DF64 C1AD DD39") }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")