use strict;
my $str = 'SIGN="000F 0E70 FA83 B72F D215 C7EE 4AF4 6440 A547 12B1 0603 \\
SN=RK:7573-0:2832397:369963
1086 0857 BFF1 5FC2 CE6F C87D 7C00 DF64 C1AD DD39") }';
my $regex = qr/SN=([A-Z]+:[\d-]+):/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}