# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"SN=([A-Z]+:[\d-]+):"
test_str = ("SIGN=\"000F 0E70 FA83 B72F D215 C7EE 4AF4 6440 A547 12B1 0603 \\\n\n"
"SN=RK:7573-0:2832397:369963\n\n"
"1086 0857 BFF1 5FC2 CE6F C87D 7C00 DF64 C1AD DD39\") }")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.