import Foundation
let pattern = #"SN=([A-Z]+:[\d-]+):"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SIGN="000F 0E70 FA83 B72F D215 C7EE 4AF4 6440 A547 12B1 0603 \
SN=RK:7573-0:2832397:369963
1086 0857 BFF1 5FC2 CE6F C87D 7C00 DF64 C1AD DD39") }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)