re = /(?:^|\n)(\d{4}(?:-\d{2}){2} (?:\d{2}:){2})\d{2}\.\d{3}( [+-]\d{2}:\d{2} )\[\d+\]( - Starting)[^\n]*(\n\1\d{2}\.\d{3}\2\[\d+\]\3[^\n]*)+/m
str = '2019-10-31 05:49:52.416 +10:00 [1] - Starting
2019-10-31 05:49:53.416 +10:00 [2] - Starting
2019-10-31 05:49:53.416 +10:00 [3] - Starting
2019-10-31 06:53:58.416 +10:00 [1] - Starting
2019-10-31 06:53:58.416 +10:00 [1] - Identical but not "starting"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end