#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:.+?%20){3}+.)(?:.+?%20){2}.+?(?:%20)?$"
Local $sString = "https://domain.com/search=any%20url%20encoded_word-here" & @CRLF & _
"https://domain.com/search=any%20url%20encoded_word-here%20" & @CRLF & _
"https://domain.com/search=z%C5%82oty%20z%C5%82oty%20z%C5%82oty" & @CRLF & _
"https://domain.com/search=z%C5%82oty%20z%C5%82ota%20%C5%82ata" & @CRLF & _
"https://domain.com/search=any%20%20word%20%20here" & @CRLF & _
"https://domain.com/search=any%20word%20here&color=blue" & @CRLF & _
"https://domain.com/search=any-1st%20word_2nd%20here3" & @CRLF & _
"" & @CRLF & _
"https://example.com/search=one%20two" & @CRLF & _
"https://domain.com/search=one%20two%20three%20four" & @CRLF & _
"https://domain.com/search=one%20%20two%20%20three%20%20four" & @CRLF & _
"https://domain.com/search=one%20%20two%20three%20%20four" & @CRLF & _
"https://domain.com/search=one%20%20two%20%20three%20%20four" & @CRLF & _
"https://domain.com/search=one%20two%20three%20four&color=blue" & @CRLF & _
"https://domain.com/search=z%C5%82oty%20z%C5%82oty%20z%C5%82oty%20word" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")