import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([01]\\d|[0-9]|2[0-3]):?([0-5]\\d)$";
final String string = "02:00\n"
+ "22:00\n"
+ "23:59\n"
+ "00:00\n"
+ "24:00\n"
+ "9:30\n"
+ "2:30";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}