package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^##\s([A-Za-z0-9]+( [A-Za-z0-9]+)+)$`)
var str = `## This Months News`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}