$re = '/\d{1,2}[\.\/-]\d{1,2}[\.\/-](?:\d{4}|\d{2})\b/m';
$str = '01.11.11
12/22/22
12/12/1981
1*51*12
22|1|13
12.23.192
03-02-1919
1-22-12
01-23-18
03-23-1984
01.11.18
2.2.17
02.02.18
12.1.16
12.23.1943
01-23-11
12.23.19';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);