const regex = /(([a-zA-Z0-9]*)(?:\s*,\s*([a-zA-Z0-9]*))*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([a-zA-Z0-9]*)(?:\\s*,\\s*([a-zA-Z0-9]*))*)', 'gm')
const str = `a1, a2, a3, a4, a5, a6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}