// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([a-zA-Z0-9]*)(?:\s*,\s*([a-zA-Z0-9]*))*)").unwrap();
let string = "a1, a2, a3, a4, a5, a6";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}