import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "discord(?:app)?\\.com\\/(?:(friend-)?invite|servers)?\\/([a-z0-9\\-]+)|discord\\.gg\\/(?:\\S+\\/)?([a-z0-9\\-]+)";
final String string = "discord.com/invite/abc123\n"
+ "discordapp.com/invite/123abc\n"
+ "discord.gg/invite/abc123\n"
+ "discord.gg/123abc\n"
+ "discord.com/friend-invite/abc123\n"
+ "discord.com/servers/123abc\n"
+ "discordapp.com/servers/abc123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}