const regex = /discord(?:app)?\.com\/(?:(friend-)?invite|servers)?\/([a-z0-9\-]+)|discord\.gg\/(?:\S+\/)?([a-z0-9\-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('discord(?:app)?\\.com\\\/(?:(friend-)?invite|servers)?\\\/([a-z0-9\\-]+)|discord\\.gg\\\/(?:\\S+\\\/)?([a-z0-9\\-]+)', 'gm')
const str = `discord.com/invite/abc123
discordapp.com/invite/123abc
discord.gg/invite/abc123
discord.gg/123abc
discord.com/friend-invite/abc123
discord.com/servers/123abc
discordapp.com/servers/abc123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}