re = /[&?]((?:firstName|lastName|phone1|address|zipcode)=|email=(?:.*@.*\.)?)[^&]*/
str = 'https://example.com/?&iframeLoad=true&firstName=David&lastName=Faber&email=xyzzy?@xyzzy.com&phone1=1234567890&address=myaddress&zipcode=myzip&isAvailableReferral=true&isAvailableDirect=false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end