#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!\d{8}|[a-f]{8})[a-f\d]{8}"
Local $sString = "online-release-0202-c3764ab8-02022329" & @CRLF & _
"online-release-0202-02022329-c3764ab8" & @CRLF & _
"online-release-0202-02022329-ffffffff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")