import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\d{8}|[a-f]{8})[a-f\\d]{8}";
final String string = "online-release-0202-c3764ab8-02022329\n"
+ "online-release-0202-02022329-c3764ab8\n"
+ "online-release-0202-02022329-ffffffff";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}