const regex = new RegExp('^.*\\[.*\\].*\\[client\\s+.*:.*\\].*authentication\\s+failure.*\\.php$', 'g')
const str = `[Thu Jan 07 21:09:50.120651 2016] [:error] [pid 26210] [client 123.123.123.123:12878] user hgfhfg authentication failure, referer: https://example.com/administrator/index.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}