re = /(?<!\S)iv(?!\S)/m
str = 'the driver of the 1st vehicle hit the iv iv at a stop'
subst = 'insuredvehicle'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result