const regex = /(\\x[0-9a-fA-F]+\[\d+m)([0-9\.]+)(\\.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\x[0-9a-fA-F]+\\[\\d+m)([0-9\\.]+)(\\\\.*)', 'gm')
const str = `\\x1b[31m42\\x1b[0m
\\x1b[32m1010\\x1b[0m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}