#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[.*\]\((?!http:)(?!.+\.md).+\)"
Local $sString = "dfg [link text 3](http://external-link...md) fgdfg" & @CRLF & _
"dfg [link text 3](http://external-link/file.ext) dfg" & @CRLF & _
"dfg [link text 3](http://external-link/file.) dfg" & @CRLF & _
"dfg [link text 3](http://external-link) dfg" & @CRLF & _
"dfg [link text 1](internal-link) dfgdg" & @CRLF & _
"dfg [link text 1](internal-link.) dfgdg" & @CRLF & _
"dfg [link text 2](internal-link-2.md) dfgdg" & @CRLF & _
"dfg [link text 2](internal-link-2.mdsdfsdf) dfgdg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")