use strict;
my $str = 'dfg [link text 3](http://external-link...md) fgdfg
dfg [link text 3](http://external-link/file.ext) dfg
dfg [link text 3](http://external-link/file.) dfg
dfg [link text 3](http://external-link) dfg
dfg [link text 1](internal-link) dfgdg
dfg [link text 1](internal-link.) dfgdg
dfg [link text 2](internal-link-2.md) dfgdg
dfg [link text 2](internal-link-2.mdsdfsdf) dfgdg
';
my $regex = qr/\[.*\]\((?!http:)(?!.+\.md).+\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}