$re = '/<li>(?!<\/li>)([^\n]+)/m';
$str = '<li>(?!"<\\/li>".*);
<li>([^\\n]+)(?!<\\/li>);
<li>(?!<\\/li> )([^<\\/li>\\n]+)
<li>(?!<\\/li>)([^\\n]+)
<li>.*(?!<\\/li>)
<li>KO </li>
<li>Ok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);