const regex = /(?<time>\d{1,2}-\d{1,2}-\d{4} +\d{1,2}:\d{1,2}:\d{1,2},\d{3}) +(?<message1>[A-Z]+) .*\[ID=(?<ID>\w+)] +\[N=(?<N>\w+)] (?<messages>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<time>\\d{1,2}-\\d{1,2}-\\d{4} +\\d{1,2}:\\d{1,2}:\\d{1,2},\\d{3}) +(?<message1>[A-Z]+) .*\\[ID=(?<ID>\\w+)] +\\[N=(?<N>\\w+)] (?<messages>.*)', 'g')
const str = `[14-10-2016 00:00:04,004 INFO WebService:1603] [172.16.1.10] [0000077000013] [ID=N0000077000013] [N=147639237688] REQUEST getStatus`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}