re = /\/([^\/]+)\/?$/
str = 'http://falloutboy.com/111
http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki
http://www.adobe.com/ru/
http://www.mamba.ru/en/
'
# Print the match result
str.match(re) do |match|
    puts match.to_s
end