using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.+?)class=\s*""([^""]*?)""";
string input = @"<h1 class=""big blue"" id=""testing""> some text </h1><div id=""foo"" class=""blue danube page-title""> some text </div><span class=""></span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}