re = /<(.+?)class=\s*"([^"]*?)"/m
str = '<h1 class="big blue" id="testing"> some text </h1><div id="foo" class="blue danube page-title"> some text </div><span class=""></span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end