# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<section[a-z=\"'\s]+>([\s\S]*?)<\/section>"
test_str = ("<chapter id=\"chap1\">\n"
"<para0><title></title></para0>\n"
"</chapter>\n\n"
"<chapter id=\"chap2\"> <title>THEORY</title>\n"
"<section id=\"Thoery\">\n"
"<title>theory Section</title>\n"
"<para0 verstatus=\"ver\">\n"
"<title>Theory Para 0 </title>\n"
"<text>blah blah</text>\n"
"</para0>\n"
"</section>\n\n"
"<section id=\"Next section\">\n"
"<title>title</title>\n"
"<para0>\n"
"<title>Title</title>\n"
"<text>blah blah</text>\n"
"</para0>\n"
"</section>\n\n"
"<section id=\"More sections\">\n"
"<title>title</title>\n"
"<para0>\n"
"<title>Title</title>\n"
"<text>blah blah</text>\n"
"</para0>\n"
"</section>\n\n"
"<section id=\"section\">\n"
"<title>title</title>\n"
"<para0>\n"
"<title>Title</title>\n"
"<text>blah blah</text>\n"
"</para0>\n"
"</section>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.