using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]+)";
string substitution = @"\L$1";
string input = @"ASDSADSAadfasdf9080DSAD908fgsd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}