const regex = /(?:eur\w*|€)?\s*([0-9\., ]+)\s*(million)?\s*(?:eur\w*|€)?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:eur\\w*|€)?\\s*([0-9\\., ]+)\\s*(million)?\\s*(?:eur\\w*|€)?', 'gmi')
const str = `EUR 7.200.000
euro 4 000
EUR 0.2 million
Main project: 300 000 EUR
1998: 43.000.000 euros`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}