# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(A[KLRZ]|C[AOT]|D[CE]|FL|GA|HI|I[ADLN]|K[SY]|LA|M[ADEINOST]|N[CDEHJMVY]|O[HKR]|PA|RI|S[CD]|T[NX]|UT|V[AT]|W[AIVY])"
test_str = ("AL Alabama\n"
"AK Alaska\n"
"AZ Arizona\n"
"AR Arkansas\n"
"CA California\n"
"CO Colorado\n"
"CT Connecticut\n"
"DE Delaware\n"
"DC District of Columbia\n"
"FL Florida\n"
"GA Georgia\n"
"HI Hawaii\n"
"ID Idaho\n"
"IL Illinois\n"
"IN Indiana\n"
"IA Iowa\n"
"KS Kansas\n"
"KY Kentucky\n"
"LA Louisiana\n"
"ME Maine\n"
"MD Maryland\n"
"MA Massachusetts\n"
"MI Michigan\n"
"MN Minnesota\n"
"MS Mississippi\n"
"MO Missouri\n"
"MT Montana\n"
"NE Nebraska\n"
"NV Nevada\n"
"NH New Hampshire\n"
"NJ New Jersey\n"
"NM New Mexico\n"
"NY New York\n"
"NC North Carolina\n"
"ND North Dakota\n"
"OH Ohio\n"
"OK Oklahoma\n"
"OR Oregon\n"
"PA Pennsylvania\n"
"RI Rhode Island\n"
"SC South Carolina\n"
"SD South Dakota\n"
"TN Tennessee\n"
"TX Texas\n"
"UT Utah\n"
"VT Vermont\n"
"VA Virginia\n"
"WA Washington\n"
"WV West Virginia\n"
"WI Wisconsin\n"
"WY Wyoming")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.