#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)remote(?:-([a-zA-Z0-9+-]+))?-jobs(?:-in-([a-zA-Z0-9+-]+))?(?:-from-([0-9]+k)-usd)?(?:\/page\/([0-9]+))?"
Local $sString = "remote-jobs" & @CRLF & _
"" & @CRLF & _
"remote-php-jobs" & @CRLF & _
"remote-php+laravel-jobs" & @CRLF & _
"" & @CRLF & _
"remote-jobs-in-oceania" & @CRLF & _
"remote-jobs-in-oceania+worldwide" & @CRLF & _
"remote-php-jobs-in-oceania+worldwide" & @CRLF & _
"remote-php+laravel-jobs-in-oceania+worldwide" & @CRLF & _
"" & @CRLF & _
"remote-jobs-in-oceania-from-20k-usd" & @CRLF & _
"remote-jobs-in-oceania+worldwide-from-20k-usd" & @CRLF & _
"remote-php-jobs-in-czech-republic+worldwide-from-20k-usd" & @CRLF & _
"remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd" & @CRLF & _
"" & @CRLF & _
"remote-jobs-in-oceania-from-20k-usd/page/2" & @CRLF & _
"remote-jobs-in-oceania+worldwide-from-20k-usd/page/2" & @CRLF & _
"remote-php-jobs-in-oceania+worldwide-from-20k-usd/page/2" & @CRLF & _
"remote-php+laravel-jobs-in-oceania+worldwide-from-20k-usd/page/2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")