// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)brown(.*)$").unwrap();
let string = "The quick brown fox jumped over the lazy white dog
first brown fox, second brown fox
";
let substitution = "white$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}