// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w*)\,([\w,]+)\s([\w:.-]*)\s(.*)").unwrap();
let string = "L2TP,info,account mk_log: user vasya logged out from 192.168.0.2 via telnet";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}