$re = '/([^;]*)(Herr|Frau)\s*(.*)/m';
$str = 'Mustermann Simon Herr Firma;nummer;beschreibung;Anzeigen';
$subst = "$2 $1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;