const regex = /^(\+)?234[0-9]*?.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+)?234[0-9]*?.*', 'gm')
const str = `0000 000 0000
01 000 0000
+234 1 000 0000
0000-000-0000
00000000000
234 000 000 0000
234(000)000-0000
234(000)000 0000
+234(000)000 0000
+234(000) 000 0000
+234(000)000-0000
2340000000000
+2340000000000
55523456565`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}