// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+)?234[0-9]*?.*").unwrap();
let string = "0000 000 0000
01 000 0000
+234 1 000 0000
0000-000-0000
00000000000
234 000 000 0000
234(000)000-0000
234(000)000 0000
+234(000)000 0000
+234(000) 000 0000
+234(000)000-0000
2340000000000
+2340000000000
55523456565";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}