#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\D]+[^\W\d_a-jln-z]?$"
Local $sString = "2323" & @CRLF & _
"23234k" & @CRLF & _
"23234m" & @CRLF & _
"" & @CRLF & _
"23234$" & @CRLF & _
"23234a" & @CRLF & _
"k" & @CRLF & _
"m"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")