$re = '/^[^\D]+[^\W\d_a-jln-z]?$/m';
$str = '2323
23234k
23234m
23234$
23234a
k
m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);