import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\+|00)?(55)\\s?)?(?:\\(?(0?[0-9]{2})\\)?\\s?)??(?:((?:9\\d|[2-9])\\d{3}\\-?\\d{4}))$";
final String string = "91234-1234\n"
+ "1291234-1234\n"
+ "12 91234-1234\n"
+ "12 912341234\n"
+ "(12) 91234-1234\n"
+ "(12) 912341234\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}