use strict;
my $str = '91234-1234
1291234-1234
12 91234-1234
12 912341234
(12) 91234-1234
(12) 912341234
';
my $regex = qr/^(?:(?:\+|00)?(55)\s?)?(?:\(?(0?[0-9]{2})\)?\s?)??(?:((?:9\d|[2-9])\d{3}\-?\d{4}))$/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}