using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:\+|00)?(55)\s?)?(?:\(?(0?[0-9]{2})\)?\s?)??(?:((?:9\d|[2-9])\d{3}-?\d{4}))$";
string input = @"91234-1234
1291234-1234
12 91234-1234
12 912341234
(12) 91234-1234
(12) 912341234
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}