# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.+?<span class="remaining">([0-9]+)?<\\/span>(.+?)<\\/span>/$1$2/gm;t' <<< "<span class=\"grey black-text lighten-2 credit-counter\"><span class=\"remaining\">2</span> credits</span>"