use strict;
my $str = '<span class="grey black-text lighten-2 credit-counter"><span class="remaining">2</span> credits</span>';
my $regex = qr/.+?<span class="remaining">([0-9]+)?<\/span>(.+?)<\/span>/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";