// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m).+?<span class="remaining">([0-9]+)?<\/span>(.+?)<\/span>"#).unwrap();
let string = "<span class=\"grey black-text lighten-2 credit-counter\"><span class=\"remaining\">2</span> credits</span>";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}