$re = '/\$(\d+)\.(\d+)/m';
$str = '$4.500';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;