use strict;
my $str = 'SELECT `Тип заканчивания`, YEAR(`Дата ввода`) AS [Год] FROM [DeleteMe13$A1:B21]
GROUP BY `Тип заканчивания`';
my $regex = qr/^([\w\W]+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Дата ввода\3{0,}\]{0,})([\w\W]+)GROUP BY(.+)$/sp;
my $subst = '$1$2$4 GROUP BY $5, $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";